MAC 10.9更换php5.4为php5.3

原来是10.8,里面内置的是5.3版本。这次升级10.9也很久了。一直没什么问题在开发中。因为屏蔽了错误信息,所以也都没有多看,但是这次测试discuz和uchome的时候,兼容问题太严重了。仔细一看错误信息确实挺多。想着还是换回php5.3版本把

1. curl -s http://php-osx.liip.ch/install.sh | bash -s 5.3
中途会让你输入root密码
接着就会下载php5.3版本的pageck 包

/**
Detected OS X Mavericks 10.9. Experimental, use at your own risk!
Get packager.tgz
Unpack packager.tgz
Please type in your password, as we want to install this into /usr/local
Password:
Start packager (may take some time)
downloading http://php-osx.liip.ch/install/5.3-10.8-frontenddev-latest.dat
downloading http://php-osx.liip.ch/install/5.3-10.8/frontenddev/5.3-10.8-frontenddev-5.3.27-20130930-102956.tar.bz2

**/
这是下载信息

已有 5 条评论
  1. 小青年

    来看老大了

    小青年 回复
  2. 麦田一根葱

    为什么要降级呢?

    麦田一根葱 回复
    1. 枫叶红秋雨

      @麦田一根葱

      本地测试的一些老程序还是5.2版本写的。不兼容5.4

      枫叶红秋雨 回复
  3. 馒头饭MADfan

    用惯windows下的那种傻瓜化的PHP环境了

    馒头饭MADfan 回复
  4. 馒头饭MADfan

    用惯windows下的那种傻瓜化的PHP环境了

    馒头饭MADfan 回复
发表新评论