debian出现apt-get: /usr/local/lib/libz.so.1: no version information available

以前在用centos的时候重新编译php的时候出现过一次这个错误。但是在debian中还没出现过。这次编译nginx的时候出现了一次

apt-get: /usr/local/lib/libz.so.1: no version information available (required by /usr/lib/libapt-pkg.so.4.10)
**apt-get update的时候出现的这个错误。google下。原来是版本的超链接错误
修复方法:
rm -rf /usr/local/lib/libz.so.1
ln -s /usr/lib/libz.so.1.2.3.4 /usr/local/lib/libz.so.1

再次更新错误消失

仅有 1 条评论
  1. Yu

    话说,像这样更新某个.so的时候,个人还是不习惯使用rm -rf 先干掉文件,而是使用
    ln -sf /usr/lib/libz.so.1.2.3.4 /usr/local/lib/libz.so.1
    这样既达到目标更新了文件又没有删除东西。。
    lib库下删点东西手都抖。

    Yu 回复
发表新评论